Jump to content
COMBATSIM Forum
Martinius

Joystick problem

Recommended Posts

Hey everyone.

I'm sorry if this has been asked before, but I have a serious problem with my joystick. As soon as I change the controls in the options screen from keyboard to joystick, well, it simply doesn't work. The plane keeps rolling clockwise and I have no control. None of the axes work. I tried running the config program, and in the diagnostic part, when I tried to run diagnostics for the joystick, it suddenly said "Test failed". I'm using a Logitech extreme 3D pro. Is something wrong with the joystick, or the laptop... or both? :D

BTW, I have EF2000 with TACTCOM.

EDIT: I have already set timed to false and swap34 to true and all that stuff.

Share this post


Link to post
Share on other sites

Martinius,

Sorry for the late reply; it's been a busy week.

Check out the "Configure Joystick" section of the EF2000 Reloaded manual (page 21 of the entire PDF, page 13 shown on the page itself). The big takeaways are to be sure that the calibration ran properly, and to cycle the "timing" on and off to get the calibration to work properly.

If it calibrates, but still acts like you describe, then try Alt+C to center the joystick in-game.

Share this post


Link to post
Share on other sites

I have found an alternative mapper file and notes about it for EF2000.

Anyone having problems with the joystick, do the following:

As a positive effect, the inside and external views with the hat will now move freely (not in pieces anymore) allowing any position of view. Just keep the hat pressed.

Do the following configuration in EF2000 Reloaded:

In the Config Options, chose FCS, Swap Axis 3&4, Button wrap.

Config > Preferences > Config Joystick > calibrate the main axes, answer NO for rudders, calibrate throttle, answer YES for Flightstick Pro.

EF2000 Reloaded > File > Folders > Dosbox AppData folder > make a BACKUP of the conf file and place it somewhere.

Open the conf file and change these values:

mapperfile=mapper_EF2000.txt

usescancodes=true

buttonwrap=true

keyboardlayout=US (US)
codepage=437 (United States)

Save the file.

Create a txt file mapper_EF2000.txt in the same dir and paste the following:

hand_shutdown "key 290 mod1"
hand_capmouse "key 291 mod1"
hand_fullscr "key 13 mod2"
hand_pause "key 19 mod2"
hand_mapper "key 282 mod1"
hand_speedlock "key 293 mod2"
hand_recwave "key 287 mod1"
hand_caprawmidi "key 289 mod1 mod2"
hand_scrshot "key 286 mod1"
hand_video "key 286 mod1 mod2"
hand_decfskip "key 288 mod1"
hand_incfskip "key 289 mod1"
hand_cycledown "key 292 mod1"
hand_cycleup "key 293 mod1"
hand_caprawopl "key 288 mod1 mod2"
hand_swapimg "key 285 mod1"
key_esc "key 27"
key_f1 "key 282"
key_f2 "key 283"
key_f3 "key 284"
key_f4 "key 285"
key_f5 "key 286"
key_f6 "key 287"
key_f7 "key 288"
key_f8 "key 289"
key_f9 "key 290"
key_f10 "key 291"
key_f11 "key 292"
key_f12 "key 293"
key_grave "key 96"
key_1 "key 49"
key_2 "key 50"
key_3 "key 51"
key_4 "key 52"
key_5 "key 53"
key_6 "key 54"
key_7 "key 55"
key_8 "key 56"
key_9 "key 57"
key_0 "key 48"
key_minus "key 45"
key_equals "key 61"
key_bspace "key 8"
key_tab "key 9"
key_q "key 113"
key_w "key 119"
key_e "key 101"
key_r "key 114"
key_t "key 116"
key_y "key 121"
key_u "key 117"
key_i "key 105"
key_o "key 111"
key_p "key 112"
key_lbracket "key 91"
key_rbracket "key 93"
key_enter "key 13"
key_capslock "key 301"
key_a "key 97"
key_s "key 115"
key_d "key 100"
key_f "key 102"
key_g "key 103"
key_h "key 104"
key_j "key 106"
key_k "key 107"
key_l "key 108"
key_semicolon "key 59"
key_quote "key 39"
key_backslash "key 92"
key_lshift "stick_0 hat 0 2" "stick_0 hat 0 8" "stick_0 hat 0 4" "stick_0 hat 0 1" "key 304"
key_lessthan "key 60"
key_z "key 122"
key_x "key 120"
key_c "key 99"
key_v "key 118"
key_b "key 98"
key_n "key 110"
key_m "key 109"
key_comma "stick_0 axis 3 0" "stick_0 axis 3 0" "stick_0 axis 3 0" "stick_0 axis 3 0" "stick_0 axis 3 0" "stick_0 axis 3 0" "stick_0 axis 3 0" "stick_0 axis 3 0" "key 44"
key_period "stick_0 axis 3 1" "key 46"
key_slash "key 47"
key_rshift "key 303"
key_lctrl "key 306"
key_lalt "key 308"
key_space "key 32"
key_ralt "key 307"
key_rctrl "key 305"
key_printscreen "key 316"
key_scrolllock "key 302"
key_pause "key 19"
key_insert "key 277"
key_home "key 278"
key_pageup "key 280"
key_delete "key 127"
key_end "key 279"
key_pagedown "key 281"
key_up "stick_0 hat 0 1" "key 273"
key_left "stick_0 hat 0 8"
key_down "stick_0 hat 0 4" "key 274"
key_right "stick_0 hat 0 2" "key 275"
key_numlock "key 300"
key_kp_divide "key 267"
key_kp_multiply "key 268"
key_kp_minus "key 269"
key_kp_7 "key 263"
key_kp_8 "key 264"
key_kp_9 "key 265"
key_kp_plus "key 270"
key_kp_4 "key 260"
key_kp_5 "key 261"
key_kp_6 "key 262"
key_kp_1 "key 257"
key_kp_2 "key 258"
key_kp_3 "key 259"
key_kp_enter "key 271"
key_kp_0 "key 256"
key_kp_period "key 266"
jbutton_0_0 "stick_0 button 0"
jbutton_0_1 "stick_0 button 1"
jaxis_0_1- "stick_0 axis 1 0"
jaxis_0_1+ "stick_0 axis 1 1"
jaxis_0_0- "stick_0 axis 0 0"
jaxis_0_0+ "stick_0 axis 0 1"
jbutton_0_2 "stick_0 button 2"
jbutton_0_3 "stick_0 button 3"
jbutton_1_0
jbutton_1_1
jaxis_0_2- "stick_0 axis 2 0"
jaxis_0_2+ "stick_0 axis 2 1"
jaxis_0_3- "stick_0 axis 3 0"
jaxis_0_3+ "stick_0 axis 3 1"
jaxis_1_0-
jaxis_1_0+
jaxis_1_1-
jaxis_1_1+
jbutton_0_4
jbutton_0_5
jhat_0_0_0 "stick_0 hat 0 1"
jhat_0_0_3 "stick_0 hat 0 8"
jhat_0_0_2 "stick_0 hat 0 4"
jhat_0_0_1 "stick_0 hat 0 2"
mod_1 "key 305" "key 306"
mod_2 "key 307" "key 308"
mod_3

You may have some difficulites with the nose-steering on the ground. Just do only the movements necessary with your joystick and not anymore, don't over-correct the movement in the other direction or your plane will start to move uncontrolled. An alternative is to disable the joystick steering, delete the entries key_comma and key_period and replace with

key_comma "key 44"
key_period "key 46"

Use comma and period to steer on the ground which will cause no trouble whatsoever as long as you don't go over 24 knots.

For any joystick problems: always hit ALT+C as soon as getting in the cockpit.

Hope this helps!

XenonS

Share this post


Link to post
Share on other sites

I know it's 3 months late mates, but thanks for the help. :D I had shelved the game due to exams and hadn't had the time to check if the fix worked. It worked wonderfully, albeit after a bit of work (I actually had to set joysticktype to 4axis). Thanks again! And thanks for the great work on reloading the game! :icon_bow:

BTW I have a general question about EF2000. Is stealth modeled in this game as it is in TAW? Because I seemed to be able to get a lock from, like, 60 miles on an F-22 that was using its radar, but couldn't get a lock on an F-117 until 20 miles.

Share this post


Link to post
Share on other sites

XenonS,

Is there a reason to use FCS instead of CH and disable the rudder axis? It appears that the rudder axis is mapped in that keymapper file.

Share this post


Link to post
Share on other sites

Yes, but I cannot remember exactly why. Years ago I have played EF2000 DOS with Dosbox and a dedicated frontend, and because I had serious joystick problems I decided to do a special key mapper with Dosbox. I also have posted on SimHQ, but I cannot retrieve the link, it must be in the archives (I saved it together with my notes about EF2000).

In the Preferences of the EF2000 config menu I skipped the rudder calibration because it gives porked results, so I replaced the hat and most SHIFT-Cursor combinations with the mapper file.

XenonS

[EDIT]

Here the SimHQ link:

http://simhq.com/forum/ubbthreads.php/ubb/showflat/Number/3459615/Searchpage/1/Main/347724/Words/EF2000/Search/true/EF2000_v2.0_DOS_-_How_to_confi#Post3459615

Share this post


Link to post
Share on other sites

Hi XenonSurf,

I also have problem getting my rudder detected successfully.
And I would like to try your setting.

However I do not understand this:

EF2000 Reloaded > File > Folders > Dosbox AppData folder > make a BACKUP of the conf file and place it somewhere.

Open the conf file and change these values:

mapperfile=mapper_EF2000.txt

usescancodes=true

buttonwrap=true

keyboardlayout=US (US)
codepage=437 (United States)

Save the file.

Create a txt file mapper_EF2000.txt in the same dir


In my ef2000 reloaded folder, I can not find File > Folders > Dosbox AppData folder.

By conf file, do you mean the dosbox-EF2000.conf ?

And which folder do you put mapper_EF2000.txt?

Please advise.

Share this post


Link to post
Share on other sites

Are you sure that your rudder is not working?

Mine doesn't look like it's working either, but twisting it causes some rudder-like motion of the plane.

Does anyone else see a well defined rudder motion in external view?

Share this post


Link to post
Share on other sites

Hi mikew,

yes, I can not get my rudder detected succesfully under your dosbox-EF2000.

when I run config.exe, then calibrate:

the rudder is not detected at all.

the joystick and throttle are detected.

running "diagnostic" > "joystick" the result is "failed",

since rudder is not detected at all.

however, when I run config.exe under dosbox 0.72

the rudder is detected, and I can calibrate it.

running "diagnostic" > "joystick" the result is "passed",

since the rudder is detected and runs fine.

However, in the game, the rudder is not centered,

but always steers to the right.

So I press Alt-C,

then the rudder does not respond anymore.

Do you know what is wrong here?

Share this post


Link to post
Share on other sites

No idea right now.

In your ef2000.cfg file, do your joystick lines look like this:

STICK=7

JOYSTICK=4000,63,63,63,63,0,126,0,126,63,0

Share this post


Link to post
Share on other sites

my ef2000.cfg:

DETAIL=1
REZ=0
CONTROL=1
STICK=15
JOYSTICK=4000,63,58,67,59,0,126,127,127,0,0
SPEECH=1
VRHELMET=0
JOY_FACTOR=100
JOYSCALE=512
SOUNDFX=1,127
MUSIC=0,127

Share this post


Link to post
Share on other sites

Let's try editing the last 4 numbers of the JOYSTICK line to be like mine, ie 0,126,63,0

Then see what (if anything) happens in the game. Don't run the config program.

Share this post


Link to post
Share on other sites

after editing the last 4 numbers,

the aircraft always steers to the right,

even after I move the rudder left and right,

it seems does not affect it,

it always steers to the right.

so I press Alt-C,

then the rudder does not respond anymore.

Share this post


Link to post
Share on other sites

I've assumed we've been talking about the twist rudder Control on a joystick, but are you talking about separate rudder pedals?

Share this post


Link to post
Share on other sites

my hotas is ch fighterstick, ch pro throttle and pedals.

they were gameport version,

but I have changed them into usb using mmjoy.

so you can say it is similar to twist rudder control on a joystick,

since all three of them are detected by windows as one controller only.

I have used this same hotas with old dos games like fleet defender and strike commander,

and it is detected successfully.

Share this post


Link to post
Share on other sites

So, is this the situation?

1. You can calibrate the joystick OK using the '3dfx EF2000' config program OK on DosBox 0.72 (not the game, as it won't find the virtual voodoo card)

2. You can't even find the rudder if you run the config program in our version of DosBox.

Right now, I can't think what we've done to screw this up for you. I'll need to go through the code, but I don't remember touching the joystick handling parts.

One question, are the joystick sections of the dosbox config files the same, ie from 'dosbox-0.72.conf' and 'dosbox-EF2000.conf'?

Share this post


Link to post
Share on other sites

the answer to both 1. and 2. is yes.

my joystick section of dosbox 0.72:

joysticktype=ch

timed=false

autofire=false

swap34=true

buttonwrap=true

I have tried timed=true but the result is the same.

Share this post


Link to post
Share on other sites

..and the joystick part of dosbox-EF2000.conf?

Just want to rule out any write problem between the Reloaded launcher and the actual file DosBox uses.

Share this post


Link to post
Share on other sites

Hi mikew,

you are correct,

there is a difference between dosbox0.72.conf and dosbox-EF2000.conf.

I don't know why I miss it,

but on dosbox-EF2000.conf:

joysticktype=fcs

timed=false

autofire=false

swap34=true

buttonwrap=true

the culprit is the joystick type.

I think I changed it to fcs after reading XenonSurf's post,

and forget to change it back.

now I change it back to ch,

then the rudder can be detected and calibrated successfully,

so it works now. :D :D :D

thanks a lot for your help.

I don't think I will find it this fast if you did not insist on comparing those two.

Share this post


Link to post
Share on other sites

after further observation,

I find that moving the rudder pedal to the very extreme left - right position,

only makes the aircraft turns not very much,

not as much if I press Shift < or Shift >.

is this normal?

Share this post


Link to post
Share on other sites

Yes, I don't get much rudder effect with the joystick either. So, it seems normal but not necessarily correct.

Does anyone else have any experience or opinion on this?

Anyway, thank's for the feedback!

I'm not sure if we can just adjust the sensitivity of just the rudder, but it's something to investigate.

Share this post


Link to post
Share on other sites

mikew,

you are very welcome.

now on my ef2000.cfg file, I have the same 4 number like yours:

0,126,63,0

are these number for rudder position?

left, right, center position and what is 0 represent?

have you tried messing around with these number?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×