Jump to content
COMBATSIM Forum

getting janes USAF,F15 and WWII FIGHTERS run on window vista


Recommended Posts

Welcome to CSim. Windows Vista... hmmm... reformat and install Windows XP? I'm in the same boat, I'm looking at buying a laptop, mostly for work, but being able to mess with some sims during breaks would be nice. Seems all the laptops today have Vista pre-loaded.

Link to post
Share on other sites

Welcome to our forum, Andy.

I did a cursory Google search for answers, but no joy.

I'm wondering is VMWare might be the short-term solution. I believe there is a VMWare beta for Vista.

VMWare allows you to run any OS as a "virtual machine" on your current OS. In essence, you'd be able to install Windows '98 or Windows XP on Vista and run all your games directly on those older OSs.

It's really something we, as a community, need to solve once and for all as this question keeps coming up almost every week now.

Volunteers?

Link to post
Share on other sites
It's really something we, as a community, need to solve once and for all as this question keeps coming up almost every week now.

Well most simmers have their obsolete systems sitting around in an attic or basement somewhere, I know I did until I moved, so you could take that and put maybe 40 bucks into it getting state of the art (for 2002 or so) RAM and video card for it.

Either that or we could beat Bill Gates to death with a sack of lyposuction leftover fat for repackaging and tweaking (usually downwards) his OS every couple-few years. By the time a Windows version is actually stable and good, he's bringing a new one out, usually more ridden with bugs than Pakistani roadkill.

As for your actual question Andy, try what Doug said. For I have no real ideas beyond those two.

Link to post
Share on other sites

Strange - I justed re-installed Janes WWII Fighters on Monday (thanks from WhizKid!). Patched it to 1.08 and fired it up. No issues but a few controller glithces but nothing I couldn't resolve by remapping my joystick to the keyboard.

~ if I can get Janes WWII Fighters to work (a late 90's game), you should have no issues getting F-15 or any another older Janes sim to work. I would strongly recommend fully patching the sims FIRST prior to starting as they addressed new technologies entering the market in doing so.

My current specs:

- XP Pro SP2

- 2Gb ram

- nVidia 7900GT (I'm using the OEM/manufacturers drivers)

- AMD 64 X2- 4800 CPU

- ASUS mobo

And it ran on the first try! :)

Link to post
Share on other sites

Thanks for the inputs i recieved from everybody as regards the vista problem. my laptop features amd turion 2.2 ghz,120 mb hard disk,512 mb ram memory,window vista home basic 32 bit,NIVIDIA GEFORCE Go 6150 video card with DirectX 10 installed whereas all these janes games ie USAF,F15 and WW II fighters need slower Direct x drivers and window xp. apart from what is suggested i need to know as to what current combat sims gamesare compatible in my abovementioned configuration so that i can ask my bro who is in the usa to send these. waiting for some excellent advise to get my games installed/started. thanks andy

Link to post
Share on other sites

Just a thought:

Can you right-click the .exe for the game, select "Properties", and is there a tab called "Compatibility"?

If so, check to see if it gives an option for Win98 or WinXP mode.

Just a wild ass guess, but I figured it was worth a try.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...