Jump to content
COMBATSIM Forum

Red Viper/ Vista Black Screen


Recommended Posts

I've fallen in love with Red Viper. Amazing work on F4..check this vid, if you haven't already seen it

My problem is with Vista, one mission will run fine, and anything after that will just go to a black screen. I have tried everything imaginable, but the problem continues.

I had it running good once, but I don't know what I did to get it running..(must have been a driver change), but something I did since then put me back to the Black Screen bug. Anyone know how to fix this?

specs: 3.4 dual

NV8800GTX

X-Fi fatality

2048 gb RAM...

Link to post
Share on other sites

Eagle,

Welcome to our forum.

I honestly don't know a single person who is running Vista and F4, so I can't be of much help.

Most of the regulars around here, including myself, are sticking with XP for the foreseeable future.

Now, if one of our folks here doesn't have an answer, you may want to try, if you haven't already, the F4 forum over at Frugals: Falcon 4 forum.

Link to post
Share on other sites

Hello. and thanks for the welcom

I used to be here way back in the late 90's...when F4 was new. Been a long time.

I've been checking all the major forums for a solution. As far as Vista goes, this is the first problem I've had with any software, except a minor crashing problem with WoE that was an easy fix.

This prob with RV seems to be directly related to drivers, or Nvidia and Vista, or something. I changed to old 100x forceware last night, and flew mission after mission for hours without ever getting the black screen loading the 3D world. However, NO EXPLOSION GRAPHICS....can't get it right.

I love the RV mod and it's flight model..just feels right, and all the cockpit shaking under high g's, the inertia and momentum of weapons...seriously making me want to scrub Vista and get a copy of XP. Hopefully I'll figure it out.

Link to post
Share on other sites

Eagle,

Welcome back :)

Let us know what you find if you're able to pinpoint this Vista problem. I'm sure it'll be valuable advice for others. That RV addon sounds great. And here I just deleted my F4 install about two weeks ago. Figures :D

Link to post
Share on other sites
Eagle,

Welcome back :)

Let us know what you find if you're able to pinpoint this Vista problem. I'm sure it'll be valuable advice for others. That RV addon sounds great. And here I just deleted my F4 install about two weeks ago. Figures :D

I'm running 158's now, and it seems to be alot more stable. All the effects are back, and I can run 4 or 5 missions without the Black Bug. Sometimes you can Esc. + E and then just reload, sometimes you have to exit the whole program and reload. I have it installed over F4:AF, and I'm thinking this might be part, at least, of the problem. I just ordered a copy of F4 binder edition (lost mine years ago) and will hack it all together with HighTilesAF and see what happens. There is a new post at Frugal's World about how to get HighTilesAF to work in F4.0

You really should get RV and fly it. It's like having a new sim. It's what F4 was meant to be. From what I read, the next version isn't too far away, either.

But, for now, the 158 forceware drivers are working the best. Of course, it'll weaken your visuals in Crysis or anything like that...

If you want to get Red Viper, everything you need is here. http://freefalcon.com/forum/view_topic.php...amp;forum_id=25

Link to post
Share on other sites

Eagle,

Glad to hear you are getting things back on track...although those occasional black screens must still be maddening.

Could it possibly be a memory leak? Recently, one of the online squads I run with was having odd lockups and freezes in Armed Assault. Luckily, the game's devs included the ability to add maxmem={insert value in kilobytes} into the command line for the game's shortcut link. We all chose maxmem=512 and 99% of our problems went away.

Thanks for those RV links. I'll be sure to download it and the hi-tiles. When I'll get F4 reinstalled, tho, ... :unsure:

Link to post
Share on other sites
Eagle,

Glad to hear you are getting things back on track...although those occasional black screens must still be maddening.

Could it possibly be a memory leak? Recently, one of the online squads I run with was having odd lockups and freezes in Armed Assault. Luckily, the game's devs included the ability to add maxmem={insert value in kilobytes} into the command line for the game's shortcut link. We all chose maxmem=512 and 99% of our problems went away.

Thanks for those RV links. I'll be sure to download it and the hi-tiles. When I'll get F4 reinstalled, tho, ... :unsure:

You're welcom. You'll like it, guarenteed.

As far as a memory leak, I don't think so. The sim actually runs great, and I'm only getting the black screen about once every fourth or fifth time. Most of the time you don't have to exit the program, but sometimes you do. It is a pain, though.

A guy at Frugals posted some command line parameters, but apparently they don't work with the RV shortcut over F4AF. I keep getting a 'you're not allowed to do that' error message. ( not permission, btw, just not allowed to change the file path name at all.) So, I've got a copy of the Original F4 on the way, and I'll try it with that.

Link to post
Share on other sites

Just an update.

I finally figured out the -g and -hires command line parameters, and they seem to help alot. So, at this point, Red Viper on Vista will still Black screen about every 5th or sixth time you hit "Fly", but you can "Esc+E" back to the briefing screen, and go right back in, and it will load. Much more stable than a stock installation.

I'm running 158.x series forceware drivers (not great for newer titles like SH4 or Crysis or anything..). Add the -g3 and -hires commands to your shortcut line, and run at whatever resolution you have available in the in-game drop down list. Run your desktop at the same res, though, or it will black screen ALOT more often. It seems you can add as much driver set FSAA and Anisotropic Filtering as you like, doesn't seem to make a difference to occurence of the black screen. I think mine is currently at 8Q. Looks pretty good, and the special effects are really nice. Far above what the original F4 is like, OR F4AF.

Doesn't seem there is any complete fix that the end user can do..it's up to the genious guys that are re-writing the F4 code. I got a response from one of them that they are going to work on it, but not yet since XP is still the "Best" operating system of choice right now. But, if the growth of Falcon is to continue, they will move forward when it becomes necessary.

Thats about as far as I can get. At least it's playable now.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...