Jump to content
COMBATSIM Forum

TAW 2.0 Known Issues and Bug Reports


Home Fries
 Share

Recommended Posts

  • Replies 537
  • Created
  • Last Reply

Top Posters In This Topic

I can't get 2.30 to work - used to work in my similar Win7 64 build so not sure if the problem is windows 10 64 but I can get to the loading menu but as soon as I press "fly" in any mission...training, capaign, same story - I get this -  "f22.dat has stopped working" message.  Any ideas where to start?  Using glide version with no mods just standard 2.30 install.  No change if I try D3D exe or other resolutions etc.  Have persused this forum but can't find similar issues so apologize if this is covered somewhere.  Can't find any F22.$$$ file in my c:/ location either.

UPDATE - I think I figured it out.  I was using nGlide wrapper.  Not sure if there was a conflict because I already had nGlide installed at a system level but even when I pointed TAW to my prior nGlide install I got the same crash.  Wierd because it works in all my other 3dfx games.  So I switched to Voodoo and bam...everything works just fine. 

Thank you!

Gino

 

Link to comment
Share on other sites

  • 11 months later...
17 hours ago, Mustsafa said:

Anyone experiencing sudden frame drops on windows 10?

3 minutes ago, DrKevDog said:

My first reaction is to suspect Polak's old header modification, in which all the .3 files use the highest LOD for an exclusively long distance (128k ?). The easy test / fix would be to substitute all the default .3 files. What else then breaks is uncertain to me in 2.0.

 

Mustsafa,

If you're running TAW 2.30 (or any version 2.21 or later), then Polak's objects are not enabled by default.  If you do have the "Objects - Maximum Draw Distance" mod enabled, then as DKD says, this could be the issue.  I have not really tested TAW in Windows 10, so I can't comment further.

For troubleshooting, it also helps if you tell us which TAW exe you're running (e.g. Glide, D3D 1024, 16 or 32 bit, etc.) and Glide wrapper+settings if applicable.  These details can be found on the TAW Configuration menu.

Link to comment
Share on other sites

20 hours ago, Home Fries said:

 

Mustsafa,

If you're running TAW 2.30 (or any version 2.21 or later), then Polak's objects are not enabled by default.  If you do have the "Objects - Maximum Draw Distance" mod enabled, then as DKD says, this could be the issue.  I have not really tested TAW in Windows 10, so I can't comment further.

For troubleshooting, it also helps if you tell us which TAW exe you're running (e.g. Glide, D3D 1024, 16 or 32 bit, etc.) and Glide wrapper+settings if applicable.  These details can be found on the TAW Configuration menu.

I turned off the "Objects - Maximum Draw Distance" mod

Used nglide/voodoo and d3d

And Still have this issue.

I will try again after I finish downloading windows updates. I hope there is a library/API or something with the download for backward compatibilities.

I also experienced extreme frame rate drops in Flaming Cliffs 2 and counter strike source.

Link to comment
Share on other sites

15 hours ago, Mustsafa said:

I turned off the "Objects - Maximum Draw Distance" mod

Used nglide/voodoo and d3d

And Still have this issue.

I will try again after I finish downloading windows updates. I hope there is a library/API or something with the download for backward compatibilities.

I also experienced extreme frame rate drops in Flaming Cliffs 2 and counter strike source.

That's the ideal configuration for a modern system, so I can't identify anything that we can do with TAW to fix the issue.  Hopefully you get the issue fixed, as it does more likely appear to be driver related.

Link to comment
Share on other sites

It's my same old 2010 laptop with i5(2.4-3.2 GHz) and gt330m.

I should start saving for a new PC.

I really wish microsoft didn't let me get stuck on updates. My internet is really slow and I some times sit for more than a month until it remembers to continue updates.

So now they are ditching backward compatibility. Something they were supposed to do in the windows ME/XP era.

(backward compatibility is an excuse to repeat old mistakes            -Wish I remember who said it )

And yes I have the latest drivers.

Link to comment
Share on other sites

A few suggestions:
1. Disconnect it from the internet. That's the only way to have any control of the Win10 update process.
2. Make sure the 'Control Panel' ', 'Power Options' is set to 'High Performance'
3. Check that your CPU fan ís running and clear from dust etc, as the CPU may be throttled due to high temperature.

Link to comment
Share on other sites

One of the tools in TAW that may be of assistance in determining what is being rendered when the slowdowns occur is the Polygon tool.

When in-game simply press Alt + 0 (zero) and you should see the following:

58d30ea272b6a_Framerate-3_009_22032017_182000-Copy.jpg.a96ed093c90c99703e0fb08e392e3e2d.jpg

FrameRate.jpg.1ee533fda3b29be15d7235bde43d6736.jpg

Use a screen capture process to capture the results, both in areas where there are slowdowns (eg:"It happens whenever I get as close as 100 miles from an enemy aircraft group ") and when not slow.

Link to comment
Share on other sites

I created some new files just to slow the TAW rate in order to study the behavior. I used the 01 Diagnostic suite to document the rates.

The 01 suite, curiously, combines the virtual cockpit MFD diagnostics with a print out for Rate and FPS.

I wonder if the rates assignments suggest rate determined compensations for slow rendering?

 

RATE

FPS

 

1

50

TAW Frame Rate Cap

2

25

 

3

16

 

4

12

 

5

10

 

6

8

7

7

 

8

6

 

9

5 or 6

 

 

 

 

Link to comment
Share on other sites

Can I get some help with an issue I am having?
 

I would really like to run at TAW at 1024x768, i know the only way to do this is to use D3D. When I do, it works for the most part but the HUD graphics are all wrong. See screengrab. Any thoughts? I have an Intel 4000 and Nvidia NV520m laptop.

Untitled.jpg

Link to comment
Share on other sites

  • 1 month later...

Hi players of that (very) old game. Played this game many years ago and wanted to do this again.

Just installed TAW 2.3 but I cannot run the game. I always get the message: "This program requires an 800x600 resolution."

Tried to run the game as win7, with 800x600 resolution, with 1024x768 res, with 1080p resolution and with all selectable gilde versions.

What are the correct settings to run the game?

My PC:

Win 10 x64

I6700K

GA-Z170X-Gaming 7

GTX 1060

16GB RAM

Thanks!

F22 TAW.JPG

Link to comment
Share on other sites

In Windows, do you have the option to set the screen resolution to 800x600?
I guess not, which is why the game is complaining.

The only time I've come across this was with an Intel GPU. A driver update was needed to support the lower resolution.
I wouldn't expect you'd need to do that with Nvidia though...

Link to comment
Share on other sites

Not sure what to suggest now...

Maybe try starting the game by double clicking on the file _f22.exe instead of going through the Launcher.

It runs OK in Win 10 for me, although I get black bands down the sides on the 2D screens when viewed on a 1920x1080 monitor.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...