Jump to content
COMBATSIM Forum

F-22 Total Air War 2.30 (Final) Released


Home Fries
 Share

Recommended Posts

Nice catch, Eagle.

The whole game.cfg thing motivated me to add a GUI editor for some of the Game.cfg options not available in the Options menu. Check out TAW 2.30 Beta 5!

BTW, if there are any other options you guys want added, I can add up to 5 more options without recoding anything. As long as they're binary options, I can just add them to the datafile.

Link to comment
Share on other sites

  • 2 weeks later...

Greetings to everybody,

I have just registered to this forum to say thank you to Home Fries.

I have just found out about ef2000 reloaded yesterday at simhq forum.

Then when installing it, I saw your logo, and remember about F22 TAW.

I have just installed F22 TAW and patch it to 2.30beta.

So far, it runs perfectly on my system.

Thanks a lot, Home Fries.

I really appreciate what you have done to the sim.

Link to comment
Share on other sites

Hi Home Fries,

Thanks for the reply.

I choose 1920x1080 resolution with nglide,
then enable TrackIR and choose FoV: widescreen.

The view from the cockpit seems fine.
However, when I choose outside view, it seems stretched.
Is this correct?

And there is a rectangle outline around the aircraft wheels,
is this a bug?

Link to comment
Share on other sites

  • 2 weeks later...

I had this working pretty well on my old win7 machine.

I did have occasional game CTD but it was not very often and not a problem.

Now with my Win8.1 computer I am having problems.

The problem is I am getting constant game freezes. (seems about 50/50 chance a few seconds after entering game3d)

They are really annoying because I can't alt Tab to desktop or end task.

Sometimes I can bring up task manager with ctrl+alt+del but still I cant end task or even log out or reboot from there : (

Only option is the reset button. It happens so often it is very annoying.

Does anyone has any idea's how I can fix or at least reduce the frequency of these freezes?

I am using nGlide wrapper at 1920x1080

Antialiasing and Anisotropic at application controlled.

Clean install. Default campaign.

Taw2.20 + 2.21 + 2.22 + 230 beta 5

Win8.1, GTX760 /347.52 driver, CPU i7-4770, RAM 8GB

Link to comment
Share on other sites

Ok, I'll give it a try. I think it is related to video and the glide wrapper.

I did try the other glide wrapper, dgVoodoo but have the freeze issue with that one too.

On my old computer I used d3d but on win8 I cant run it in d3d without really bad corruption.

I didnt test d3d much beaucse of that and I didnt try software yet but

I'll give it a try.

Link to comment
Share on other sites

Ok I tested some more, with software mode, 800x600.

I still get the game freeze( goes to black screen after alt+tab and back)

but now also a CTD without freeze. The error said "DDupdateFast3dWindowPalette():could not update palette"

:( I am starting think the only way I can play this on my new computer is to install win7.

Link to comment
Share on other sites

Personally, I haven't noticed any problem with Win8.1 so am not sure what to suggest next.

There's usually a text file in your root c:/ folder called f22.$$$, which gives the reason for the last crash....but if the game freezes, this might not be updated.

Ok, I found one entry there. "Cannot open \lev\coll.dat"

I have no idea what that means though or if its related to the freezes.

Link to comment
Share on other sites

That could point to a timing issue between the game and the Windows file system.

While Windows is fairly good these days at allocating resources, there are still some more intrusive background processes (eg Norton Anti-virus, NSA keyloggers etc) that could screw things up.

So, maybe it's worth having a look at what else is running....

Link to comment
Share on other sites

That's interesting, I do have Avast AV.

I did try one other thing.

Running the game on only one CPU core. That trick has helped with a few other games.

I did also notice much more steady fps when running on just one core.

Anyway, it might have been a fluke but I was able to play without freeze for quite along time.

I did some alt+tab in and out and even tried a test recording with MSI Afterburner with no freezes or ctd's.

Not sure if running the game on just 1 core would help with the timing issues? It did seem to work in my little test though. Hope it wasn't a fluke :)

_

On a different subject here a bit. How do most people capture game video with this game?

OBS and FFspit would not work and the only other one I normal use is Nvidia shadowplay but that didn't work either with this game.

MSI Afterburner did work but I got an awful fps drop when recording :(

Link to comment
Share on other sites

OK, I think I have it fixed.

Running for a couple of hours last night and then again today, no freezes, no ctd.

I setup the launcher with "RunWithAffinity" to put a desktop shortcut. The launcher then runs F22.dat on one core, no more freezes.

Also I did finally mange to get ShadowPlay to record ok. Just needed to setup hotkey for manual recording.

So, everything is good now and with FSAA it looks great :)

I think there is a little problem with my computer. I do have some odd stutter in some games, mostly older games like GTR2 but also some newer

games like Assetto Corsa. Running the games on 1 or 2 cores fixes the stutter and I guess in this case that stutter caused TAW to freeze and ctd.

___

I would like to take this opportunity to thank everyone involved with these patches and keeping TAW alive.

All the work gone into it and with everything, mods, reference manuals, all in a simple install and fixes for modern hardware. :) Thanks guys.

I never would have got it all to work with just my old CD in the drive. lol

Thanks guys

Link to comment
Share on other sites

mdj2000, thanks for the reminder and apologies for not supplying what you want yet.

The current situation is that I have extracted most of the files from what you supplied and at least one of the possible exe files, of which there are many.

What needs to be done next is to collate these files into a core set that is common to all languages, then the language specific sections can be treated separately.

Personally, I lack the time to do this right now.

For the extraction work, I've been using python scripts, so please PM me if you are familiar with this and want to help with this stuff yourself.

Link to comment
Share on other sites

  • 3 weeks later...

Hi, I am playing the 2.30 beta version. Perfect game! ^^

I am not sure if it has already been discussed in this topic, but here's a tip for the best in-game music (it worked for me):

Make sure that the AWE card's Wave Effects Synthesis option is selected as the default MIDI device in the Control Panel

Multimedia settings. To check, go to
Start->Settings->Control Panel->Multimedia->MIDI, and select MIDI for Creative Advanced Wave Effects Synthesis.
Note: this comes from the ADF Readme file.
Link to comment
Share on other sites

  • 4 weeks later...

Hello there!

I just found my original F22 ADF and RSO CD-s, and played in the last few days (with nGlide 1.04). As I was looking through the internet I found this awesome project. I just finished with downloading the necessary files, and installing, and could not wait to get right in the middle of the action, but a problem encountered.

I installed the "TAW_220_Install", and applied the "TAW_221_Patch", and after that the "TAW_222a_Patch", and the "TFX_Soundtrack_SB16_for_TAW20". After every installation I restarted the PC.

After being finished with the configuring in the Graphics and Applications Configuration in the Launcher, I could not start the game from the files menu. I always get an error message in a window with this sign:
"Failed to get DirectInput Property DIJOFS_Y
The requested object does not exist or another application has a higher priority or this property cannot be changed"

I could not find relevant information and an answer to my problem neither through google nor on this forum, since I don't know anything about game modding or programming. Any help, would be greatly appreciated.
My configuration: MoBo>>ASUS P5K, Intel C2D E8400, Sapphire Radeon HD7770 with the catalyst 14.4 released 04-25-2014, 3 GB Kingston DDR2-800 C5 Rams in 4 DIMM-s, and of course enough space on SATA II HDD-s running in IDE emulation due to ASUS's AHCI licencing problems, and did not wanted to flash it with modded BIOS. OS: WinXP x86 with almost all the updates installed until january of 2014.

Thank You in advice!

Link to comment
Share on other sites

I have a feeling this is the fact that TAW only detects the first controller on your system. If your first controller is something like the Thrustmaster MFD, then there are no analog axes to detect and you may get this error.

I need to know what controllers you have, and what order they are in, in order to better troubleshoot this issue.

Link to comment
Share on other sites

Thank you for the fast answer. Since I am an autosim fan too, I left my Thrustmaster Ferrari 458 Italia plugged in.
I just pulled it out, and then the game started. Now running the game with keyboard, but I am planning to get and old sound card with gameport, and run the game with my 12 years old Saitek ST50. :D Now everything is clear, I tried ADF with my wheel earlier just for fun, and did not have anything to control the Y axis.
I would have never thought, that pulling out my racing wheel will solve the problem. Thank you very very much for your answer. Now I can see from the first training mission (take off), that this game has awesome graphics, going to spend hours with that in future. :)

Link to comment
Share on other sites

  • 3 weeks later...

I have a problem. When I opening tawmenu.exe I give a two massage

1." Could not open necessary datafiles. Make sure docs.cfg is in your \Config\ folder."

2. "Could not open Custom Skin datafile. You will have the default skins restored."

I click ok but still massage pop out.

Somebody can help me?

I have Windows 8.1.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...