Jump to content

This is a Fine How Do You Do!


Admin
 Share

Recommended Posts

Well kids, life can really kick you in the 'nads!

I installed a fresh version of the old message board on my local machine here (it's really quite sweet, I must say), and I was all ready to restore the database backups when I ran into a rather nasty problem.

For some INEXPLICABLE &$%*@#!!!! reason, the backup files that were gzipped (.gz file extension) by the old board's Admin backup script utility are all corrupted and I can't open them!

I can only surmise that the friggin' dialogue box that popped up when the backup was complete should've warned me that it might be possible that the local machine (my machine) would download the file in ASCII mode and to do an FTP binary download to be on the safe side.

So, what I have is a bunch of garbage backup files and a toasted hard drive. Let's see:

- Garbage Backup Files + Toasted Hard Drive = Bubkis! Nada! Zilch! Zero! Bugger all!

I tried using the repair feature in WinRAR, but still nothing.

So, unless any of you know how to rescue a .gz file that was transferred in ASCII, well, those old posts are well and truly gonzo!

[stomps out of room ....SLAM!]

Link to comment
Share on other sites

"gunzip complains about corrupted data or a CRC error

99.9% of the problems with gzip are due to file transfers done in ASCII mode instead of BINARY mode. In particular, gopher is known to corrupt binary files by considering them as ASCII. Make sure that your local copy of the file has exactly the same byte size as the original.

If you have transferred a file in ASCII mode and you no longer have access to the original, you can try the program fixgz to remove the extra CR (carriage return) bytes inserted by the transfer. A Windows 9x/NT/2000/ME/XP binary is here. But there is absolutely no guarantee that this will actually fix your file. Conclusion: never transfer binary files in ASCII mode. To compile fixgz and run it, do:

cc -o fixgz fixgz.c

fixgz bad.gz fixed.gz

gzip -tv fixed.gz"

http://www.gzip.org/

:)

Link to comment
Share on other sites

I've seen dis before Doug when we were restoring the db a few years ago. Let me see if I can dig up my old csim notebook when I get back from teaching tonight...

Don't bother, bro.

The backup files were incomplete garbarge. The data be gone for good.

Link to comment
Share on other sites

 Share

×
×
  • Create New...