Jump to content

HELP: Multiple issue's with running TAW.


Recommended Posts

I have multiple questions

1. Launching TAW requires me to manually put my PC resolution on 800x600. This was never the case before. How can i fix this.
ERROR: This program requires an 800x600 display resolution but was unable to obtain it. Please use the display settings control panel to make 800x600 available.
Select OK to resume or CANCEL.

When i press OK the same message just appears again. Is this because i'm using an LCD TV display this time?

2. Also when i use the wrappers and then i go fly the graphics are all kind of purple, green and other colours. This is with almost all settings i tried. The plane and the world itself shows these weird colours. Please help. I can only play it with Direct 3D 800x600.

3. I also can't STREAM my flying. When i start to stream my flying with OBS it does show the HUD and cockpit and all the MFD information (MFD background is also black). But the outside world is almost totally black. Sometimes you can see the contours of the terrain displayed as a bunch of spread out colorful pixels. Is there a way to stream this correctly with OBS?
It actually display's the same issue when i make a screenshot.
The rest is actually streaming correctly. So the War room works. And the AWACS works while streaming. Even the little live action window streams correctly and the world is being displayed correctly there. Until i start flying. See the vid below.


4. I tried to run TAW in window mode. But it stills runs normally when i select that. So how to run this game properly in window mode? I tried making a shortcut and put -window behind it. But that does not work as well. ALT + ENTER also does not work.

See my stream her: 


Link to comment
Share on other sites

Ok so i did some test. Putting my TV monitor on 60hz actually does fix the 800x600 on startup error. But this also causes my in game graphics to be all kind of colours as you can see in one of the screenshots above. If i got back to 30Hz then the 800x600 error pops back up. So then i have to manually put my screen rez in 800x600 before i can play. In both 30hz en 60hz the wrappers always seem to give me those colourful graphics.

Using the configure D3D 1024 button also only works when my screen res is 800x600. But this time this option does not show the ingame graphics to be all colourful. But the Field of view full screen option shows me a part of the bottom screen to be black. So the game is not filling the entire screen anymore (It does show everything that should be shown. And the menu is still full screen as well.)

EDIT: Putting windows screen rez on 1280x1024 (was first 1920x1080) also fixes the colourful graphics (but still shows the black band on the bottom). So now i can also use all the wrappers.

PROBLEM 1 FIXED: Put the monitor on 60Hz
PROBLEM 2 FIXED: Change screen resolution to 1280x1024 (Actually it seems that i have to keep changing resolution. Otherwise the weird graphics glitch spontaneously comes back on a next restart)

Link to comment
Share on other sites

So i asked OBS about the streaming part.. And this was there answer: "the layering that the game is doing is causing parts of the gameplay to not be in the field of view capturable by the bitblt capture method"

Are there any settings i can try to make the layering capturable. Maybe by changing some settings in the DGVoodoo app?

Link to comment
Share on other sites

On 8/12/2020 at 8:36 PM, mikew said:

Have you tried the Glide version?

I use dgVoodoo 1 included with TAW 2.30. Works OK on my TV.


While i know that dgVoodoo 2 is also a D3D wrapper, I haven't tried it with TAW.



It's weird. It seems to work sometimes after several restarts. I thought i had figured it out. But if it works i can fly it totally fine for hours with no issue's at all. Only streaming seems to be an issue now. Streaming the war room and AWACS is all fine. Until i jump in a plane.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...